WordPress requirements

To run WordPress you need to ensure that your server meets certain requirements. The recommended requirements are:

  • PHP version 7.2 or higher;
  • MySQL version 5.6 or higher (you can also run WordPress on MariaDB 10.0 or higher);
  • HTTPS support (this has become mandatory in terms of good SEO).

If you are interested in specific server software, WordPress recommends Apache or Nginx as reliable solutions that are feature-rich enough to get you started.

To find out Visual Composer requirements, please visit requirements section of our Help Center.